Start a new topic

Windows 10 1803 Update and Running QuoteWerks SQL off a Linux Share

Hi,


So I would thought I would just provide some details about windows 10 1803 update and running QuoteWerks off a network (samba linux) connection.


We have QW in node mode running on a linux(ubuntu server) using samba. Our Our Quotewerks back end is SQL Based


As of Windows update 1803, they have removed SMB v1 from the protocols for samba. As this has many vulns to various malicious attacks.


I noticed after this windows update I could not connect (QW node connection) and was receiving the following error.


image


Though the error message talks about issues with database connections, this wasnt the case. I used the QW dbconnection tool to check that the windows 10 1803 computer could connect fine.

I could also ping the serverm and no changes had been made to the SQL Server recently.


See here for suggested QW fixes.


https://www.quotewerks.com/kbase/showArticle.asp?articleid=6546


None of the suggestions worked. So I had the inkling that this was due to the 1803 update made to my pc last week, but I wasnt sure what.


So googling around a LOT of people had reported issues with regards to windows 10 1803 update and issues with linux boxes running samba. In our case, we run a linux box using samba.


So, to test you can from powershell check what version on samba your windows box is connecting to a network share.


From powershell type

get-smbConnection


This will show what samba connections you have and specifically what dialect your connecting via.


Looking below, my dialect shows 2.0.2. Please note, this is after upgrading my Samba Server.


However previous to this I was running 1.5.0.
Which has been shutdown in Windows 10 1803


image


If your running a Linux server with samba shares, the suggested fix is to update the smb.conf file to ensure its uses a higher protocol.


In the global section of the smb.conf file, you need to specify the protocol to be at least 2


image


Then restart samba


Then ensure from your windows box you have no connected samba drives. Or restart.


On restart and remapping any network (samba drives) this boots the protocol version to 2


Now I can connect to quotewerks successfully.


Some references:

https://www.riedmann.it/blog/?p=303

http://woshub.com/windows-10-1803-cant-run-exe-files-shared-folders/

http://mindwatering.com/SupportRef.nsf/webpg/2F8B4D9961D2146785258169005CBCD0


Hopefully, if someone has this issue in future, it might be helpful.....


brendan





Thanks for the time taken with troubleshooting this one and posting such a comprehensive post. I'm sure this will save someone a good chunk of time if they come up against a similar issue!

Thanks, Brendan, for sharing this.  We started noticing issues with users on SQL running QuoteWerks over a network share when the 1803 update got pushed heavily the last two weeks.  I had found a Microsoft forum where other users were discussing the problem for other databases, and several had found enabling SMBv2 to seem to resolve the issue.  We had suggested it to a few users but hadn't heard from anyone yet if that resolved the situation definitively.  Thank you for confirming!


Just as a note, for anyone finding this thread, here is a Microsoft article on detecting and enabling SMB
https://support.microsoft.com/en-gb/help/2696547/how-to-detect-enable-and-disable-smbv1-smbv2-and-smbv3-in-windows-and
Don't forget to reboot every machine after changes.  

Login or Signup to post a comment